App maken: ook jij kunt het leren!

 

de iOS Academie Forums

Forums - Producten van de iOS Academie - Het eBook: Apps bouwen met Swift: Mach error -308 - ipc/mig server died

Erwin  Erwin heeft nog geen Studiekaart. Klokje13 okt 2015, 22:33
Avatar
Avatar
Berichten:9


Hallo!

Zojuist vol goede moed begonnen met het lezen van de ebook Apps bouwen met Swift - Programmeren met Swift. Maar ik loop bij 1.2 We starten onze eerste app (p.21 van 413) al tegen een probleem aan.

De simulator blijft zwart wanneer ik deze 'run' en wanneer ik de simulator afsluit krijg ik de volgende melding in Xcode:

"The operation couldn't be completed. (Mach error -308 - (ipc/mig) server died)".

 

Ook al maak ik de achtergrond van de view geel (of een andere kleur) de simulator blijft zwart.

Daarnaast als ik op de 'appeltje' + SHIFT + H druk verschijnt het Apple logo en daaronder een dunne grijze balk. Dit probleem heb ik met iedere simulator van de iPad 2 tot en met de iPhone 6s Plus.

 

Wat kan ik er aan doen om dit probleem op te lossen? De simulator is zo onbruikbaar.

Zou iemand mij hiermee kunnen helpen?

Alvast bedankt!

 

Gr.

Erwin

(lid sinds 1 dag)

Reageer


AppChanger  Laurens heeft nog geen Studiekaart. Klokje14 okt 2015, 15:40
Avatar
Avatar
Berichten:301
Fans:13


Hallo Erwin,

Je kan eens proberen om Xcode opnieuw te installeren.

Hoe start je de eerste app? Begin je met een Single view Application?

Met vriendelijke groeten,

Laurens

Reageer


Erwin  Erwin heeft nog geen Studiekaart. Klokje14 okt 2015, 16:38
Avatar
Avatar
Berichten:9


Hoi Laurens,

Bedankt voor je reactie.

Xcode heb ik gedeinstalleerd d.m.v. de volgende stappen uit te voeren:

- Opstarten terminal

- Invoeren command: sudo /Developer/Library/uninstall-devtools --mode=all  (bron:http://recomhub.com/blog/how-to-uninstall-xcode-on-mac-os-x/)

- Xcode vanuit programma's naar de prullenbak slepen

- Xcode 7.0.1. opnieuw downloaden en installeren vanuit de App Store

- Computer opnieuw afsluiten

- Opstarten Xcode 7.0.1.

- Conform het eBook het template Single view Application aangeklikt

- De applicatie d.m.v. 'appeltje'+R starten 

En toen bleek dat ik wederom dezelfde melding krijg.

 

Ik denk dat het iets structureels is, maar ik denk dat er meerdere mogelijkheden zijn:

- Xcode is onvoldoende goed verwijderd, waardoor ik geen goede 2e start maak --> op een andere manier Xcode deinstalleren. Weet iemand een andere manier?

- Ik zou deze versie kunnen verwijderen en een oudere versie kunnen installeren

- Ik zou de beta versie kunnen installeren

Hoe denk(en) jij/jullie erover? Welke opties heb ik nog meer om deze error te voorkomen.

 

Gr.

Erwin

Reageer


AppChanger  Laurens heeft nog geen Studiekaart. Klokje14 okt 2015, 19:57
Avatar
Avatar
Berichten:301
Fans:13


Hall Erwin,

Probeer anders dit ook nog eens.

http://www.appletips.nl/een-trage-mac-cache-bestanden-opruimen/

Met vriendelijke groeten,

Laurens

Reageer


Erwin  Op de eerste vier stappen van zijn/haar studiekaart scoort Erwin 74%. Klokje18 okt 2015, 22:48
Avatar
Avatar
Berichten:63


Hallo!

Zojuist vol goede moed begonnen met het lezen van de ebook Apps bouwen met Swift - Programmeren met Swift. Maar ik loop bij 1.2 We starten onze ...

Hoi naamgenoot, heeft met de werking van Playground te maken. Installeer de nieuwste verzie van Xcode 7.01 en het is afgelopen.

Reageer


Erwin  Erwin heeft nog geen Studiekaart. Klokje19 okt 2015, 20:23
Avatar
Avatar
Berichten:9


Hall Erwin,

Probeer anders dit ook nog eens.

http://www.appletips.nl/een-trage-mac-cache-bestanden-opruimen/

Met vriendelijke groeten,

Hallo Laurens,

Nog voor ik je tip heb uitgevoerd is het me gelukt de simulator te starten d.m.v. lang te wachten (5 minuten ofzo de 1e keer) het screen een paar keer te draaien, een paar keer te locken en te unlocken en vervolgens een paar keer op de home button te drukken. Daarna klik ik op de app en krijg ik eerst nog de volgende melding:

Developer Tools Access moet de controle over een ander proces overnemen om foutopsporing te kunnen voortzetten. Typ uw wachtwoord om dit toe te staan.

Gebruikersnaam:

Wachtwoord:

Vervolgens druk ik gewoon op annuleren (soms meer dan 1x) en dan wordt de app eindelijk gestart. Al met al voor de eerste keer starten heel omslachtig, maar het werkt wel =D!

Jou tip heb ik trouwens daarna ook uitgevoerd, maar er was geen verschil. Ik heb nu wel lekker 1 GB cache opgeschoond.

Ik kan voorlopig nog vooruit maar het blijft wel een 'irritator'.

Gr.

Erwin

 

Reageer

Leuk! 1 persoon vindt vindt dit leuk.

Erwin  Erwin heeft nog geen Studiekaart. Klokje19 okt 2015, 20:26
Avatar
Avatar
Berichten:9


Hoi naamgenoot, heeft met de werking van Playground te maken. Installeer de nieuwste verzie van Xcode 7.01 en het is afgelopen.

...

Hoi Erwin,

Bedankt voor de tip, maar ik maak al gebruik van 7.0.1.. De simulator start nu wel, maar dat kost wel onnodig veel tijd en handeling (zie mijn bovenstaande reactie naar Laurens).

Gr.

Erwin

Reageer